using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)N[0o]\.\s?-?\s?[A-Z0-9]";
string input = @"Kaline bypassed the Minors to join the Tigers at 18. By 20
No.-1
N0.-1";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}