const regex = /(?i)N[0o]\.\s?-?\s?[A-Z0-9]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?i)N[0o]\\.\\s?-?\\s?[A-Z0-9]', 'gm')
const str = `Kaline bypassed the Minors to join the Tigers at 18. By 20
No.-1
N0.-1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}