$re = '/(?i)N[0o]\.\s?-?\s?[A-Z0-9]/m';
$str = 'Kaline bypassed the Minors to join the Tigers at 18. By 20
No.-1
N0.-1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);