using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"--([^:=]+)[:=](.*?)(?=\s+--|\z)";
string input = @"--property:value --property:value with spaces --property:value_with_underscores --property=value --property=value with spaces --property=value_with_underscores --property:value-with-dashes";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}