$re = '/--([^:=]+)[:=](.*?)(?=\s+--|\z)/';
$str = '--property:value --property:value with spaces --property:value_with_underscores --property=value --property=value with spaces --property=value_with_underscores --property:value-with-dashes';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);