package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^(>|<)?(\d+)(\.\d+)?(\.\d+)?$|
^(\d+)(\.\d+)?(\.\d+)?-(\d+)(\.\d+)?(\.\d+)?$)`)
var str = `>1.1
<2.0.1
2.2.0-1
1.0.2-1.3
20.20.1-5
1.1
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}