re = /(^(>|<)?(\d+)(\.\d+)?(\.\d+)?$|
^(\d+)(\.\d+)?(\.\d+)?-(\d+)(\.\d+)?(\.\d+)?$)/m
str = '>1.1
<2.0.1
2.2.0-1
1.0.2-1.3
20.20.1-5
1.1
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end