// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(^(>|<)?(\d+)(\.\d+)?(\.\d+)?$|
^(\d+)(\.\d+)?(\.\d+)?-(\d+)(\.\d+)?(\.\d+)?$)").unwrap();
let string = ">1.1
<2.0.1
2.2.0-1
1.0.2-1.3
20.20.1-5
1.1
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}