import Foundation
let pattern = #"(?:['"]?([\\\w\d ]+)['"]?(?:,\s*)?)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #" 'font1', 'font 2', font3, "font 4 1", "\C560\D50C SD \C0B0\B3CC\ACE0\B515 Neo";"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)