package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(.*)(;)(.*)`)
var str = `asdf[;asdf]`
var substitution = ";$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}