use strict;
my $str = 'asdf[;asdf]';
my $regex = qr/(.*)(;)(.*)/p;
my $subst = ';$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";