using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=[^{]|^)\{\{\s*([Uu]ncat(egori[sz]ed)?|[Nn]ocat|[Nn]eedscategory|[Cc]ategori[sz]e)[^}]*\}\}";
string input = @"{{nocat}}
{{nocat|}}
{{{nocat}}}
{{{nocat|}}}
{{{nocat|yes}}}
{{{nocat|true}}}
{{{nocat|<noinclude>1</noinclude>}}}
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}