$re = '/(?=[^{]|^)\{\{\s*([Uu]ncat(egori[sz]ed)?|[Nn]ocat|[Nn]eedscategory|[Cc]ategori[sz]e)[^}]*\}\}/m';
$str = '{{nocat}}
{{nocat|}}
{{{nocat}}}
{{{nocat|}}}
{{{nocat|yes}}}
{{{nocat|true}}}
{{{nocat|<noinclude>1</noinclude>}}}
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);