import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=[^\\{]|^)\\{\\{\\s*([Uu]ncat(egori[sz]ed)?|[Nn]ocat|[Nn]eedscategory|[Cc]ategori[sz]e)[^\\}]*\\}\\}";
final String string = "{{nocat}}\n"
+ "{{nocat|}}\n"
+ "{{{nocat}}}\n"
+ "{{{nocat|}}}\n"
+ "{{{nocat|yes}}}\n"
+ "{{{nocat|true}}}\n"
+ "{{{nocat|<noinclude>1</noinclude>}}}\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}