using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((\w{4}\d{2}|\d{2}\w{4})(,|$))+";
string input = @"JEAN01,JEAN02,03JEAN,JEAN04";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}