$re = '/^((\w{4}\d{2}|\d{2}\w{4})(,|$))+/';
$str = 'JEAN01,JEAN02,03JEAN,JEAN04';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);