package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^((\w{4}\d{2}|\d{2}\w{4})(,|$))+`)
var str = `JEAN01,JEAN02,03JEAN,JEAN04`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}