using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=^\d+)^([78]\d{10}|[1]\d{9}|[0](?:\d{6}[78]|\d{7}[1])(?:\d{10}|\d{9}))";
string input = @"85556987456
75556987456
1555698745
000000085556987456
000000075556987456
000000001556987456";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}