package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[\s\S]*?password=[\s\S]*`)
var str = `This is the first line
Here is password=SECRET second line
Here is third line`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}