$re = '/^[\s\S]*?password=[\s\S]*/m';
$str = 'This is the first line
Here is password=SECRET second line
Here is third line';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);