re = /^[\s\S]*?password=[\s\S]*/m
str = 'This is the first line
Here is password=SECRET second line
Here is third line'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end