use strict;
my $str = '<!DOCTYPE html>
<html lang="en" dir="ltr" class="client-nojs">
<head>
<meta charset="UTF-8" />
<title>International English Language Testing System - Wikipedia, the free encyclopedia</title>
<meta name="generator" content="MediaWiki 1.25wmf2" />
<script type="text/javascript">(function() {var walkme = document.createElement(\'script\'); walkme.type = \'text/javascript\'; walkme.async = true; walkme.src=\'http://cdn.walkme.com/users/cb643dab0d6f4c7cbc9d436e7c06f719/walkme_cb643dab0d6f4c7cbc9d436e7c06f719.js\'; var s = document.getElementsByTagName(\'script\')[0]; s.parentNode.insertBefore(walkme, s); window._walkmeConfig = {smartLoad:true}; })();</script>
<link rel="alternate" href="android-app://org.wikipedia/http/en.m.wikipedia.org/wiki/International_English_Language_Testing_System" />
<link rel="alternate" type="application/x-wiki" title="Edit this page" href="/w/index.php?title=International_English_Language_Testing_System&action=edit" />
';
my $regex = qr/<script(?:\s+(?>"[\S\s]*?"|'[\S\s]*?'|(?:(?!\/>)[^>])?)+)?\s*>[\S\s]*?http:\/\/cdn\.walkme\.com\/users[\S\s]*?<\/script\s*(?=>)>/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}