import Foundation
let pattern = #"<script(?:\s+(?>"[\S\s]*?"|'[\S\s]*?'|(?:(?!\/>)[^>])?)+)?\s*>[\S\s]*?http:\/\/cdn\.walkme\.com\/users[\S\s]*?<\/script\s*(?=>)>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<!DOCTYPE html>
<html lang="en" dir="ltr" class="client-nojs">
<head>
<meta charset="UTF-8" />
<title>International English Language Testing System - Wikipedia, the free encyclopedia</title>
<meta name="generator" content="MediaWiki 1.25wmf2" />
<script type="text/javascript">(function() {var walkme = document.createElement('script'); walkme.type = 'text/javascript'; walkme.async = true; walkme.src='http://cdn.walkme.com/users/cb643dab0d6f4c7cbc9d436e7c06f719/walkme_cb643dab0d6f4c7cbc9d436e7c06f719.js'; var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(walkme, s); window._walkmeConfig = {smartLoad:true}; })();</script>
<link rel="alternate" href="android-app://org.wikipedia/http/en.m.wikipedia.org/wiki/International_English_Language_Testing_System" />
<link rel="alternate" type="application/x-wiki" title="Edit this page" href="/w/index.php?title=International_English_Language_Testing_System&action=edit" />
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}