import re
regex = re.compile(r"<script(?:\s+(?>\"[\S\s]*?\"|'[\S\s]*?'|(?:(?!\/>)[^>])?)+)?\s*>[\S\s]*?http:\/\/cdn\.walkme\.com\/users[\S\s]*?<\/script\s*(?=>)>")
test_str = ("<!DOCTYPE html>\n"
"<html lang=\"en\" dir=\"ltr\" class=\"client-nojs\">\n"
"<head>\n"
"<meta charset=\"UTF-8\" />\n"
"<title>International English Language Testing System - Wikipedia, the free encyclopedia</title>\n"
"<meta name=\"generator\" content=\"MediaWiki 1.25wmf2\" />\n"
"<script type=\"text/javascript\">(function() {var walkme = document.createElement('script'); walkme.type = 'text/javascript'; walkme.async = true; walkme.src='http://cdn.walkme.com/users/cb643dab0d6f4c7cbc9d436e7c06f719/walkme_cb643dab0d6f4c7cbc9d436e7c06f719.js'; var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(walkme, s); window._walkmeConfig = {smartLoad:true}; })();</script>\n"
"<link rel=\"alternate\" href=\"android-app://org.wikipedia/http/en.m.wikipedia.org/wiki/International_English_Language_Testing_System\" />\n"
"<link rel=\"alternate\" type=\"application/x-wiki\" title=\"Edit this page\" href=\"/w/index.php?title=International_English_Language_Testing_System&action=edit\" />\n")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")