using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[-+]?(\d{1,3}|,\d{3})+(\.\d+)?";
string input = @"7,336.82, -3.89, -0.05 7,351.60 7,322.86 7,340.71
ok: 1,000,000
bad: 1,000,00.0";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}