const regex = /[-+]?(\d{1,3}|,\d{3})+(\.\d+)?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[-+]?(\\d{1,3}|,\\d{3})+(\\.\\d+)?', 'g')
const str = `7,336.82, -3.89, -0.05 7,351.60 7,322.86 7,340.71
ok: 1,000,000
bad: 1,000,00.0`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}