// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[-+]?(\d{1,3}|,\d{3})+(\.\d+)?").unwrap();
let string = "7,336.82, -3.89, -0.05 7,351.60 7,322.86 7,340.71
ok: 1,000,000
bad: 1,000,00.0";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}