use strict;
my $str = '@Test(enabled=true, groups = { "set_6", "set_6.producction", "set_6.cdma", "aaa", "aaa.activates" })
@CitrusTest(name = "AAA - CDMA Activate non-existing subscriber")
public void AAA_CDMA_Activate_NonExisting_Subscriber(){
description("NEs: AAASL1 (AAA_STG1_HTTP), MBREQ1, MBSYNCREQ1, UISYNCREQ1, MBAAARSP");
/* *********************************** TEST DATA ************************************ */
variable("NEName", "AAASL1");
variable("NECategory", "AAAServer");
variable("MEID", "${MEID}");
variable("MEID2", "${MEID}");
variable("MDN", "${MDN_5}");
variable("MIN", "${MIN_5}");
variable("CorrelationHandle", "${0063_CorrelationHandle}");
/* *********************************************************************************** */
sendBackEndRequest(request.CDMA_DELETE);
sendBackEndRequest(request.CDMA_ACTIVATE);
applyBehavior(new SendVerify(request.PSB_VERIFY, "verifySoapClient"));
receive(action -> action.endpoint("verifySoapClient")
.schemaValidation(false)
.validateNamespace("vs", "http://www.verizonwireless.com/mtas/schema/VerifySubscriber")
.validateNamespace("res", "http://www.verizonwireless.com/mtas/schema/Response")
.validate("//vs:VerifyResponse/vs:VerifyResponseContent/vs:NeVerifyResults/vs:NetworkElementCode", "${NEName}")
.validate("//vs:VerifyResponse/vs:VerifyResponseContent/vs:NeVerifyResults/vs:Status/vs:Code", "FOUND")
.validate("//vs:NetworkElementAttributes/vs:NetworkElementParameters[vs:Name=\'meidHex\']/vs:Value", "@equalsIgnoreCase(\'${MEID}\')@")
.validate("//vs:NetworkElementAttributes/vs:NetworkElementParameters[vs:Name=\'DMU_KEY_STATE\']/vs:Value", "update-keys")
.validate("//vs:NetworkElementAttributes/vs:NetworkElementParameters[vs:Name=\'ServiceIndicators\']/vs:Value", "MNAI-DUN,IP_POOL_ID-General_FES")
.validate("//vs:NetworkElementAttributes/vs:NetworkElementParameters[vs:Name=\'domain\']/vs:Value", "vzw3g.com"));
sendBackEndRequest(request.CDMA_DELETE);
}
@Test(enabled=true, groups = { "set_6", "aaa", "aaa.deletes" })
@CitrusTest(name = "AAA - CDMA Delete existing subscriber")
public void AAA_CDMA_Delete_Existing_Subscriber(){
description("NEs: AAASL1 (AAA_STG1_HTTP), MBREQ1, MBSYNCREQ1, UISYNCREQ1, MBAAARSP");
/* *********************************** TEST DATA ************************************ */
variable("NEName", "AAASL1");
variable("NECategory", "AAAServer");
variable("MEID", "${MEID}");
variable("MEID2", "${MEID}");
variable("MDN", "${MDN_5}");
variable("MIN", "${MIN_5}");
variable("ICCID", "${0063_ICCID}");
variable("IMSI_VZW", "${0063_IMSI_VZW}");
variable("IMSI_VOD", "${0063_IMSI_VOD}");
variable("EUIMID", "${0063_EUIMID}");
variable("RateCenter", "${RateCenter}");
variable("CorrelationHandle", "${0063_CorrelationHandle}");
/* *********************************************************************************** */
sendBackEndRequest(request.CDMA_DELETE);
sendBackEndRequest(request.CDMA_ACTIVATE);
applyBehavior(new SendVerify(request.PSB_VERIFY, "verifySoapClient"));
receive(action -> action.endpoint("verifySoapClient")
.schemaValidation(false)
.validateNamespace("vs", "http://www.verizonwireless.com/mtas/schema/VerifySubscriber")
.validateNamespace("res", "http://www.verizonwireless.com/mtas/schema/Response")
.validate("//vs:VerifyResponse/vs:VerifyResponseContent/vs:NeVerifyResults/vs:NetworkElementCode", "${NEName}")
.validate("//vs:VerifyResponse/vs:VerifyResponseContent/vs:NeVerifyResults/vs:Status/vs:Code", "FOUND")
.validate("//vs:NetworkElementAttributes/vs:NetworkElementParameters[vs:Name=\'meidHex\']/vs:Value", "@equalsIgnoreCase(\'${MEID}\')@")
.validate("//vs:NetworkElementAttributes/vs:NetworkElementParameters[vs:Name=\'DMU_KEY_STATE\']/vs:Value", "update-keys")
.validate("//vs:NetworkElementAttributes/vs:NetworkElementParameters[vs:Name=\'ServiceIndicators\']/vs:Value", "MNAI-DUN,IP_POOL_ID-General_FES")
.validate("//vs:NetworkElementAttributes/vs:NetworkElementParameters[vs:Name=\'domain\']/vs:Value", "vzw3g.com"));
sendBackEndRequest(request.CDMA_DELETE);
applyBehavior(new SendVerify(request.PSB_VERIFY, "verifySoapClient"));
receive(action -> action.endpoint("verifySoapClient")
.schemaValidation(false)
.validateNamespace("vs", "http://www.verizonwireless.com/mtas/schema/VerifySubscriber")
.validateNamespace("res", "http://www.verizonwireless.com/mtas/schema/Response")
.validate("//vs:VerifyResponse/vs:VerifyResponseContent/vs:NeVerifyResults/vs:NetworkElementCode", "${NEName}")
.validate("//vs:VerifyResponse/vs:VerifyResponseContent/vs:NeVerifyResults/vs:Status/vs:Code", "NOTFOUND")
.validate("//vs:VerifyResponse/vs:VerifyResponseContent/vs:NeVerifyResults/vs:Status/vs:Description", "Subscriber not found"));
}';
my $regex = qr/@Test\s*\((?P<params>[^@\n]*)\)\s+(@\w+\s*\([^@\n]*\s*)*@CitrusTest\((?P<name>[^@\n]*)\)((?!(public|private|protected)).*\n\s*)+(public|private|protected)\s+(?P<return_type>\w+)\s+(?P<method>[\w-]+)\s*\(.*\)\s*{\s*description\w*\(\w*\".*:\s*(?P<NEs>[\w-]+\s+(\([\w-]+\))?(\s*,\s+[\w-]+)*)\s*\"\s*\)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}