# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"@Test\s*\((?P<params>[^@\n]*)\)\s+(@\w+\s*\([^@\n]*\s*)*@CitrusTest\((?P<name>[^@\n]*)\)((?!(public|private|protected)).*\n\s*)+(public|private|protected)\s+(?P<return_type>\w+)\s+(?P<method>[\w-]+)\s*\(.*\)\s*{\s*description\w*\(\w*\".*:\s*(?P<NEs>[\w-]+\s+(\([\w-]+\))?(\s*,\s+[\w-]+)*)\s*\"\s*\)"
test_str = ("@Test(enabled=true, groups = { \"set_6\", \"set_6.producction\", \"set_6.cdma\", \"aaa\", \"aaa.activates\" })\n"
" @CitrusTest(name = \"AAA - CDMA Activate non-existing subscriber\")\n"
" public void AAA_CDMA_Activate_NonExisting_Subscriber(){\n"
" description(\"NEs: AAASL1 (AAA_STG1_HTTP), MBREQ1, MBSYNCREQ1, UISYNCREQ1, MBAAARSP\");\n"
" \n"
" /* *********************************** TEST DATA ************************************ */\n"
" variable(\"NEName\", \"AAASL1\");\n"
" variable(\"NECategory\", \"AAAServer\");\n"
" variable(\"MEID\", \"${MEID}\");\n"
" variable(\"MEID2\", \"${MEID}\");\n"
" variable(\"MDN\", \"${MDN_5}\");\n"
" variable(\"MIN\", \"${MIN_5}\");\n\n"
" variable(\"CorrelationHandle\", \"${0063_CorrelationHandle}\"); \n"
" /* *********************************************************************************** */\n\n"
" sendBackEndRequest(request.CDMA_DELETE);\n"
" \n"
" sendBackEndRequest(request.CDMA_ACTIVATE);\n\n"
" applyBehavior(new SendVerify(request.PSB_VERIFY, \"verifySoapClient\"));\n"
" receive(action -> action.endpoint(\"verifySoapClient\")\n"
" .schemaValidation(false)\n"
" .validateNamespace(\"vs\", \"http://www.verizonwireless.com/mtas/schema/VerifySubscriber\")\n"
" .validateNamespace(\"res\", \"http://www.verizonwireless.com/mtas/schema/Response\")\n"
" .validate(\"//vs:VerifyResponse/vs:VerifyResponseContent/vs:NeVerifyResults/vs:NetworkElementCode\", \"${NEName}\")\n"
" .validate(\"//vs:VerifyResponse/vs:VerifyResponseContent/vs:NeVerifyResults/vs:Status/vs:Code\", \"FOUND\")\n"
" .validate(\"//vs:NetworkElementAttributes/vs:NetworkElementParameters[vs:Name='meidHex']/vs:Value\", \"@equalsIgnoreCase('${MEID}')@\")\n"
" .validate(\"//vs:NetworkElementAttributes/vs:NetworkElementParameters[vs:Name='DMU_KEY_STATE']/vs:Value\", \"update-keys\")\n"
" .validate(\"//vs:NetworkElementAttributes/vs:NetworkElementParameters[vs:Name='ServiceIndicators']/vs:Value\", \"MNAI-DUN,IP_POOL_ID-General_FES\")\n"
" .validate(\"//vs:NetworkElementAttributes/vs:NetworkElementParameters[vs:Name='domain']/vs:Value\", \"vzw3g.com\"));\n"
" \n"
" sendBackEndRequest(request.CDMA_DELETE);\n"
" }\n\n"
" @Test(enabled=true, groups = { \"set_6\", \"aaa\", \"aaa.deletes\" })\n"
" @CitrusTest(name = \"AAA - CDMA Delete existing subscriber\")\n"
" public void AAA_CDMA_Delete_Existing_Subscriber(){\n"
" description(\"NEs: AAASL1 (AAA_STG1_HTTP), MBREQ1, MBSYNCREQ1, UISYNCREQ1, MBAAARSP\");\n"
" \n"
" /* *********************************** TEST DATA ************************************ */\n"
" variable(\"NEName\", \"AAASL1\");\n"
" variable(\"NECategory\", \"AAAServer\");\n"
" variable(\"MEID\", \"${MEID}\");\n"
" variable(\"MEID2\", \"${MEID}\");\n"
" variable(\"MDN\", \"${MDN_5}\");\n"
" variable(\"MIN\", \"${MIN_5}\");\n"
" \n"
" variable(\"ICCID\", \"${0063_ICCID}\");\n"
" variable(\"IMSI_VZW\", \"${0063_IMSI_VZW}\");\n"
" variable(\"IMSI_VOD\", \"${0063_IMSI_VOD}\");\n"
" variable(\"EUIMID\", \"${0063_EUIMID}\");\n"
" variable(\"RateCenter\", \"${RateCenter}\");\n\n"
" variable(\"CorrelationHandle\", \"${0063_CorrelationHandle}\");\n"
" \n"
" /* *********************************************************************************** */\n\n"
" sendBackEndRequest(request.CDMA_DELETE);\n"
" \n"
" sendBackEndRequest(request.CDMA_ACTIVATE);\n\n"
" applyBehavior(new SendVerify(request.PSB_VERIFY, \"verifySoapClient\"));\n"
" receive(action -> action.endpoint(\"verifySoapClient\")\n"
" .schemaValidation(false)\n"
" .validateNamespace(\"vs\", \"http://www.verizonwireless.com/mtas/schema/VerifySubscriber\")\n"
" .validateNamespace(\"res\", \"http://www.verizonwireless.com/mtas/schema/Response\")\n"
" .validate(\"//vs:VerifyResponse/vs:VerifyResponseContent/vs:NeVerifyResults/vs:NetworkElementCode\", \"${NEName}\")\n"
" .validate(\"//vs:VerifyResponse/vs:VerifyResponseContent/vs:NeVerifyResults/vs:Status/vs:Code\", \"FOUND\")\n"
" .validate(\"//vs:NetworkElementAttributes/vs:NetworkElementParameters[vs:Name='meidHex']/vs:Value\", \"@equalsIgnoreCase('${MEID}')@\")\n"
" .validate(\"//vs:NetworkElementAttributes/vs:NetworkElementParameters[vs:Name='DMU_KEY_STATE']/vs:Value\", \"update-keys\")\n"
" .validate(\"//vs:NetworkElementAttributes/vs:NetworkElementParameters[vs:Name='ServiceIndicators']/vs:Value\", \"MNAI-DUN,IP_POOL_ID-General_FES\")\n"
" .validate(\"//vs:NetworkElementAttributes/vs:NetworkElementParameters[vs:Name='domain']/vs:Value\", \"vzw3g.com\"));\n"
" \n"
" sendBackEndRequest(request.CDMA_DELETE);\n"
" \n"
" applyBehavior(new SendVerify(request.PSB_VERIFY, \"verifySoapClient\"));\n"
" receive(action -> action.endpoint(\"verifySoapClient\")\n"
" .schemaValidation(false)\n"
" .validateNamespace(\"vs\", \"http://www.verizonwireless.com/mtas/schema/VerifySubscriber\")\n"
" .validateNamespace(\"res\", \"http://www.verizonwireless.com/mtas/schema/Response\")\n"
" .validate(\"//vs:VerifyResponse/vs:VerifyResponseContent/vs:NeVerifyResults/vs:NetworkElementCode\", \"${NEName}\")\n"
" .validate(\"//vs:VerifyResponse/vs:VerifyResponseContent/vs:NeVerifyResults/vs:Status/vs:Code\", \"NOTFOUND\")\n"
" .validate(\"//vs:VerifyResponse/vs:VerifyResponseContent/vs:NeVerifyResults/vs:Status/vs:Description\", \"Subscriber not found\"));\n"
" }")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.