import Foundation
let pattern = #"@Test\s*\((?P<params>[^@\n]*)\)\s+(@\w+\s*\([^@\n]*\s*)*@CitrusTest\((?P<name>[^@\n]*)\)((?!(public|private|protected)).*\n\s*)+(public|private|protected)\s+(?P<return_type>\w+)\s+(?P<method>[\w-]+)\s*\(.*\)\s*{\s*description\w*\(\w*\".*:\s*(?P<NEs>[\w-]+\s+(\([\w-]+\))?(\s*,\s+[\w-]+)*)\s*\"\s*\)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
@Test(enabled=true, groups = { "set_6", "set_6.producction", "set_6.cdma", "aaa", "aaa.activates" })
@CitrusTest(name = "AAA - CDMA Activate non-existing subscriber")
public void AAA_CDMA_Activate_NonExisting_Subscriber(){
description("NEs: AAASL1 (AAA_STG1_HTTP), MBREQ1, MBSYNCREQ1, UISYNCREQ1, MBAAARSP");
/* *********************************** TEST DATA ************************************ */
variable("NEName", "AAASL1");
variable("NECategory", "AAAServer");
variable("MEID", "${MEID}");
variable("MEID2", "${MEID}");
variable("MDN", "${MDN_5}");
variable("MIN", "${MIN_5}");
variable("CorrelationHandle", "${0063_CorrelationHandle}");
/* *********************************************************************************** */
sendBackEndRequest(request.CDMA_DELETE);
sendBackEndRequest(request.CDMA_ACTIVATE);
applyBehavior(new SendVerify(request.PSB_VERIFY, "verifySoapClient"));
receive(action -> action.endpoint("verifySoapClient")
.schemaValidation(false)
.validateNamespace("vs", "http://www.verizonwireless.com/mtas/schema/VerifySubscriber")
.validateNamespace("res", "http://www.verizonwireless.com/mtas/schema/Response")
.validate("//vs:VerifyResponse/vs:VerifyResponseContent/vs:NeVerifyResults/vs:NetworkElementCode", "${NEName}")
.validate("//vs:VerifyResponse/vs:VerifyResponseContent/vs:NeVerifyResults/vs:Status/vs:Code", "FOUND")
.validate("//vs:NetworkElementAttributes/vs:NetworkElementParameters[vs:Name='meidHex']/vs:Value", "@equalsIgnoreCase('${MEID}')@")
.validate("//vs:NetworkElementAttributes/vs:NetworkElementParameters[vs:Name='DMU_KEY_STATE']/vs:Value", "update-keys")
.validate("//vs:NetworkElementAttributes/vs:NetworkElementParameters[vs:Name='ServiceIndicators']/vs:Value", "MNAI-DUN,IP_POOL_ID-General_FES")
.validate("//vs:NetworkElementAttributes/vs:NetworkElementParameters[vs:Name='domain']/vs:Value", "vzw3g.com"));
sendBackEndRequest(request.CDMA_DELETE);
}
@Test(enabled=true, groups = { "set_6", "aaa", "aaa.deletes" })
@CitrusTest(name = "AAA - CDMA Delete existing subscriber")
public void AAA_CDMA_Delete_Existing_Subscriber(){
description("NEs: AAASL1 (AAA_STG1_HTTP), MBREQ1, MBSYNCREQ1, UISYNCREQ1, MBAAARSP");
/* *********************************** TEST DATA ************************************ */
variable("NEName", "AAASL1");
variable("NECategory", "AAAServer");
variable("MEID", "${MEID}");
variable("MEID2", "${MEID}");
variable("MDN", "${MDN_5}");
variable("MIN", "${MIN_5}");
variable("ICCID", "${0063_ICCID}");
variable("IMSI_VZW", "${0063_IMSI_VZW}");
variable("IMSI_VOD", "${0063_IMSI_VOD}");
variable("EUIMID", "${0063_EUIMID}");
variable("RateCenter", "${RateCenter}");
variable("CorrelationHandle", "${0063_CorrelationHandle}");
/* *********************************************************************************** */
sendBackEndRequest(request.CDMA_DELETE);
sendBackEndRequest(request.CDMA_ACTIVATE);
applyBehavior(new SendVerify(request.PSB_VERIFY, "verifySoapClient"));
receive(action -> action.endpoint("verifySoapClient")
.schemaValidation(false)
.validateNamespace("vs", "http://www.verizonwireless.com/mtas/schema/VerifySubscriber")
.validateNamespace("res", "http://www.verizonwireless.com/mtas/schema/Response")
.validate("//vs:VerifyResponse/vs:VerifyResponseContent/vs:NeVerifyResults/vs:NetworkElementCode", "${NEName}")
.validate("//vs:VerifyResponse/vs:VerifyResponseContent/vs:NeVerifyResults/vs:Status/vs:Code", "FOUND")
.validate("//vs:NetworkElementAttributes/vs:NetworkElementParameters[vs:Name='meidHex']/vs:Value", "@equalsIgnoreCase('${MEID}')@")
.validate("//vs:NetworkElementAttributes/vs:NetworkElementParameters[vs:Name='DMU_KEY_STATE']/vs:Value", "update-keys")
.validate("//vs:NetworkElementAttributes/vs:NetworkElementParameters[vs:Name='ServiceIndicators']/vs:Value", "MNAI-DUN,IP_POOL_ID-General_FES")
.validate("//vs:NetworkElementAttributes/vs:NetworkElementParameters[vs:Name='domain']/vs:Value", "vzw3g.com"));
sendBackEndRequest(request.CDMA_DELETE);
applyBehavior(new SendVerify(request.PSB_VERIFY, "verifySoapClient"));
receive(action -> action.endpoint("verifySoapClient")
.schemaValidation(false)
.validateNamespace("vs", "http://www.verizonwireless.com/mtas/schema/VerifySubscriber")
.validateNamespace("res", "http://www.verizonwireless.com/mtas/schema/Response")
.validate("//vs:VerifyResponse/vs:VerifyResponseContent/vs:NeVerifyResults/vs:NetworkElementCode", "${NEName}")
.validate("//vs:VerifyResponse/vs:VerifyResponseContent/vs:NeVerifyResults/vs:Status/vs:Code", "NOTFOUND")
.validate("//vs:VerifyResponse/vs:VerifyResponseContent/vs:NeVerifyResults/vs:Status/vs:Description", "Subscriber not found"));
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)