$re = '@\[\*\](.+?)\[/\*\]@m';
$str = '[*]prova[/*]';
$subst = "<li>\1</li>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;