re = /\[\*\](.+?)\[\/\*\]/m
str = '[*]prova[/*]'
subst = '<li>\\1</li>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result