import Foundation
let pattern = #"\[\*\](.+?)\[/\*\]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"[*]prova[/*]"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<li>\1</li>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)