const regex = /(?:\G(?!^)|(?<!\S)\S{5})\K\S/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\G(?!^)|(?<!\\S)\\S{5})\\K\\S', 'gm')
const str = `I hate extra spaces elephant`;
const subst = `.`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);