$re = '/(?:\G(?!^)|(?<!\S)\S{5})\K\S/m';
$str = 'I hate extra spaces elephant';
$subst = ".";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;