re = /(?:\G(?!^)|(?<!\S)\S{5})\K\S/m
str = 'I hate extra spaces elephant'
subst = '.'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result