import re
regex = re.compile(r"Pixel 6$", flags=re.MULTILINE)
test_str = ("Pixel 7 Pro\n"
"Pixel 7\n"
"Pixel 3\n"
"Pixel 3 XL\n"
"Pixel 6\n"
"Pixel 4\n"
"Pixel 5\n"
"Pixel 3a\n"
"Pixel 6 Pro\n"
"Pixel 6 Pro\n"
"Pixel 3\n"
"Pixel 3 XL\n"
"Pixel 3a\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")