import Foundation
let pattern = #"Pixel 6$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Pixel 7 Pro
Pixel 7
Pixel 3
Pixel 3 XL
Pixel 6
Pixel 4
Pixel 5
Pixel 3a
Pixel 6 Pro
Pixel 6 Pro
Pixel 3
Pixel 3 XL
Pixel 3a
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)