// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)Pixel 6$").unwrap();
let string = "Pixel 7 Pro
Pixel 7
Pixel 3
Pixel 3 XL
Pixel 6
Pixel 4
Pixel 5
Pixel 3a
Pixel 6 Pro
Pixel 6 Pro
Pixel 3
Pixel 3 XL
Pixel 3a
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}