package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)map (\d+) (.*) into (.*)`)
var str = `map 12 grams into kilograms
map 12 square meter into square centimeter`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}