$re = '/map (\d+) (.*) into (.*)/m';
$str = 'map 12 grams into kilograms
map 12 square meter into square centimeter';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);