re = /map (\d+) (.*) into (.*)/m
str = 'map 12 grams into kilograms
map 12 square meter into square centimeter'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end