using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"map\s+(\d+)\s+(.*?)\s+into\s+(.*)";
string input = @"map 12 grams into kilograms
map 12 square meter into square centimeter";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}