const regex = /map\s+(\d+)\s+(.*?)\s+into\s+(.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('map\\s+(\\d+)\\s+(.*?)\\s+into\\s+(.*)', 'gm')
const str = `map 12 grams into kilograms
map 12 square meter into square centimeter`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}