// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)map\s+(\d+)\s+(.*?)\s+into\s+(.*)").unwrap();
let string = "map 12 grams into kilograms
map 12 square meter into square centimeter";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}