using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^M{0,4}(CM|CD|D?C{0,3})(XC|XL|L?X{0,3})(IX|IV|V?I{0,3})$";
string input = @"XM
XIV
III
XLVIII
MMDCCXXVI
IIIIIIII
XCXCXC";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}