package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^M{0,4}(CM|CD|D?C{0,3})(XC|XL|L?X{0,3})(IX|IV|V?I{0,3})$`)
var str = `XM
XIV
III
XLVIII
MMDCCXXVI
IIIIIIII
XCXCXC`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}