$re = '/^M{0,4}(CM|CD|D?C{0,3})(XC|XL|L?X{0,3})(IX|IV|V?I{0,3})$/m';
$str = 'XM
XIV
III
XLVIII
MMDCCXXVI
IIIIIIII
XCXCXC';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);