import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\((?=[^)]*[a-zA-Z ])[^)]+?\\)";
final String string = "(3) will not be replaced\n\n"
+ "(1234) will not be replaced\n\n"
+ "(some letters) will be replaced\n\n"
+ "(some letters, spaces - and numbers 123) will be replaced";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}