re = /\((?=[^)]*[a-zA-Z ])[^)]+?\)/
str = '(3) will not be replaced
(1234) will not be replaced
(some letters) will be replaced
(some letters, spaces - and numbers 123) will be replaced'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end